Back to overview
Degraded
Performance Degradation
Sep 19 at 11:31am BST
Affected services
Portal
API
Resolved
Sep 19 at 11:36am BST
The platform has now returned to its expected performance levels. We are working with our supplier to further investigate the issue.
Affected services
Portal
API
Created
Sep 19 at 11:31am BST
We are currently encountering challenges with our infrastructure provider, resulting in performance issues throughout our platform. Rest assured, we are actively engaged with them and investigating.
Affected services
Portal
API