Back to overview
Degraded

Reports Unavailable

Feb 06 at 08:29am GMT
Affected services
Reports

Resolved
Feb 06 at 12:05pm GMT

We have identified the issue behind the report menu disappearing and applied a hotfix! We apologise for the inconvenience caused and thank you for bearing with us.

Created
Feb 06 at 08:29am GMT

We apologize for the inconvenience, but the Reports menu is temporarily unavailable. Our team is working to resolve this issue promptly. Thank you for your patience, and we'll keep you updated on the progress.