Back to overview
Degraded

Camera Connectivity

Nov 19 at 01:18am GMT
Affected services
Tracking Data - Cameras

Resolved
Nov 19 at 12:14pm GMT

Our supplier has completed the emergency maintenance and the issue affecting live camera statuses has now been resolved. Data is flowing normally again.

We will continue to monitor, but no further impact is expected.
Thank you for your patience throughout this incident.

Updated
Nov 19 at 10:10am GMT

Our supplier has confirmed that emergency maintenance is still in progress. The work is expected to be completed within the next hour.

We will continue to monitor the situation and provide further updates as needed.
Thank you for your continued patience.

Created
Nov 19 at 01:18am GMT

We are aware of an issue affecting the availability of some live camera statuses on the platform.
Some devices may appear offline or last-seen several hours ago despite currently being on the road. This is related to emergency maintenance being carried out by one of our suppliers.

We are investigating and will provide further updates as necessary.
Thank you for your patience and understanding.