Back to overview
Degraded
Camera Footage Issues
Jun 2, 2026 at 8:00pm UTC
Affected services
Cameras - Video Download
Resolved
Jun 3, 2026 at 9:00pm UTC
All issues with video thumbnails and stuck downloads should now be resolved.
Thank you for your patience and understanding.
Affected services
Created
Jun 2, 2026 at 8:00pm UTC
We are aware of an issue whereby certain video thumbnails are not correctly displaying, and some video footage is not available to view and appears stuck in the final stages of download.
Thank you for your understanding while we actively investigate these issues.
Affected services