Camera Issues
Resolved
Jul 14, 2026 at 10:18am UTC
Our supplier has confirmed their fix is in place and camera streaming/downloads should now be functioning again.
Thank you for your patience and understanding.
Affected services
Updated
Jul 14, 2026 at 10:00am UTC
We are working with our supplier on a resolution, expected to be delivered within the next 15 minutes (11:15 BST/10:15 UTC)
Affected services
Created
Jul 14, 2026 at 8:30am UTC
We are currently experiencing an issue with our supplier which is causing issues retrieving footage from a subset of cameras.
We will provide an update in due course.
Thank you for your patience and understanding.
Affected services