Back to overview
Degraded

Mobile Network Provider Issue

May 12 at 09:45am BST
Affected services
Mobile Network A

Resolved
May 12 at 01:40pm BST

The issue was resolved as of 13:40 on the 12th May.

Created
May 12 at 09:45am BST

We have been advised of an issue at our mobile network provider which is stopping data traffic into our portal for processing.