Back to overview
Degraded
Mobile Network degraded service
Jun 07 at 07:16pm BST
Affected services
Mobile Network A
Resolved
Jun 07 at 07:56pm BST
We have now seen a return to normal levels of inbound data - This incident is now set at resolved.
Affected services
Mobile Network A
Created
Jun 07 at 07:16pm BST
We are seeing a reduction in data traffic coming into us from our mobile network provider. We have escalated to our provider. Further updates will be provided as this progresses.
Affected services
Mobile Network A