Back to overview
Degraded

Verilocation Portal Performance Issues

Jun 11 at 12:40pm BST
Affected services
Portal
API

Resolved
Jun 11 at 02:25pm BST

Normal performance levels have been resumed. We sincerely apologise for the impact on your business today. We will continue to monitor the situation and will provide further updates only if necessary.

Updated
Jun 11 at 01:39pm BST

We continue to work urgently on the issue affecting the Verilocation Portal and API. Regular updates will be provided to keep you informed. We understand the importance of this service and sincerely apologise for the impact on your business.

Created
Jun 11 at 12:40pm BST

We are aware of an issue affecting the Verilocation portal. Our teams are working urgently to resolve this issue, and we will provide regular updates on our progress.