Data Delays
Resolved
Feb 24 at 04:54pm GMT
The earlier delays affecting data processing for some devices have now been resolved. All systems are operating normally, and data is being processed in real time. We will continue to monitor performance closely. Thank you for your patience and understanding.
Affected services
Updated
Feb 24 at 02:48pm GMT
Please be aware we are carrying out further maintenance to alleviate the data delays and will provide a further update shortly thereafter.
Affected services
Created
Feb 24 at 10:27am GMT
We are currently investigating an issue causing data delays for some devices. Our team is actively working to identify the root cause and restore normal processing as quickly as possible. We’ll provide further updates as soon as we have more information. Thank you for your patience.
Affected services